nixos-config/machines/kholinar/hardware.nix
Charlotte Van Petegem 3ac95c39bf
All checks were successful
Cachix / build (elendel) (push) Successful in 1m43s
Cachix / build (kholinar) (push) Successful in 2m8s
Cachix / build (marabethia) (push) Successful in 1m35s
kholinar: No displaylink anymore, thank god
2025-01-03 22:00:00 +01:00

74 lines
1.5 KiB
Nix

{ config, lib, pkgs, modulesPath, ... }:
{
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
boot = {
loader = {
systemd-boot.enable = true;
efi.canTouchEfiVariables = true;
};
initrd = {
availableKernelModules = [ "xhci_pci" "nvme" "usbhid" "usb_storage" "sd_mod" "sdhci_pci" ];
kernelModules = [ "i915" ];
};
kernelModules = [ "kvm-intel" ];
extraModulePackages = [ ];
kernel.sysctl = {
"vm.swappiness" = 1;
};
};
fileSystems."/" = {
device = "rpool/local/root";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/nix" = {
device = "rpool/local/nix";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/data" = {
device = "rpool/safe/data";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/cache" = {
device = "rpool/local/cache";
fsType = "zfs";
neededForBoot = true;
};
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/BEEE-D83A";
fsType = "vfat";
};
swapDevices = [
{ device = "/dev/disk/by-uuid/6c09b90f-8971-4702-a18a-f06dfb3d8dcd"; }
];
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
hardware = {
cpu.intel.updateMicrocode = true;
enableRedistributableFirmware = true;
graphics = {
enable = true;
extraPackages = with pkgs; [
vaapiIntel
vaapiVdpau
libvdpau-va-gl
intel-media-driver
];
};
};
services = {
fstrim.enable = true;
xserver.videoDrivers = [ "modesetting" "fbdev" ];
};
}